Configuración
Ocultar noticias
Ocultar búsqueda
Desactivar efectos del tema
Cambiar apariencia



0 Usuarios y 1 Visitante están viendo este tema.

*
Veran, estoy intentando crear un proyecto con LibGDX, que es un framework para desarrollo de juegos multiplataforma en lenguaje java, quiero desarrollar uno para android pero para eso necesito las herramientas de la linea de comandos de android sdk, me la baje y al ejecutar el android.bat no se me abre el android sdk manager como debería suceder, sino que se me abre el cmd por un segundo y se cierra, nada más, intenté abrirlo desde el cmd de windows y este es el error que me da:



Busqué muchas soluciones en internet pero todas son diferentes y en unas hay que hacer unas cosas y en otras otras, por favor, si alguien sabe qué hacer frente a este error que me diga paso a paso qué hacer para ejecutar el android.bat  :(

Linkback: http://minecraftmin.net/index.php?topic=15533.0
« Última modificación: Enero 22, 2018, 06:20:17 pm por Alfomega »
*
Lo primero que te dice es que el comando que usas está obsoleto y que uses el sdkmanager.bat para usar las herramientas en línea de comandos.
Lo último es que no has puesto el camando como es y te da una lista de los comandos posibles.
Vamos, que revises que has puesto todo bien.
Alfomega

*
Lo primero que te dice es que el comando que usas está obsoleto y que uses el sdkmanager.bat para usar las herramientas en línea de comandos.
Lo último es que no has puesto el camando como es y te da una lista de los comandos posibles.
Vamos, que revises que has puesto todo bien.

Jaja lo voy a intentar, igual me bajé el SDK pero instalándome directamente el android studio y su SDK mánager, instalé los plugins para eclipse y me actualicé las herramientas SDK desde ahí, ahora tengo importado el proyecto de libgdx pero me da error el eclipse en una clase, por ejemplo me da error la línea que hace que herede de AndroidApplication, cuando lo selecciono me dice esto: "The type android.app.Activity cannot be resolved. It is indirectly referenced from required .class files." y la verdad estoy aprendiendo y no manejo mucho todas las excepciones en java, por eso pedía esta ayuda, y en otros me pone que configure el build path, por eso quería ver qué hay que hacer.
*
Lo primero que te dice es que el comando que usas está obsoleto y que uses el sdkmanager.bat para usar las herramientas en línea de comandos.
Lo último es que no has puesto el camando como es y te da una lista de los comandos posibles.
Vamos, que revises que has puesto todo bien.

Jaja lo voy a intentar, igual me bajé el SDK pero instalándome directamente el android studio y su SDK mánager, instalé los plugins para eclipse y me actualicé las herramientas SDK desde ahí, ahora tengo importado el proyecto de libgdx pero me da error el eclipse en una clase, por ejemplo me da error la línea que hace que herede de AndroidApplication, cuando lo selecciono me dice esto: "The type android.app.Activity cannot be resolved. It is indirectly referenced from required .class files." y la verdad estoy aprendiendo y no manejo mucho todas las excepciones en java, por eso pedía esta ayuda, y en otros me pone que configure el build path, por eso quería ver qué hay que hacer.


Ahí te dice que no está bien importado. Vamos, que no lo has añadido correctamente o que has cambiado de librería o lugar la misma. Prueba a poner la barra de escribir al final de cada uno de ellas y darle a Ctrl espacio para ver si se referencia solo.
*
Creo que encontré una solución, y es que según leí este error se debe a que en esta versión de SDK eliminaron el comando que ejecutaba, y queda volver a la versión 25.2.5. Por si les pasa lo mismo, aquí está el enlace para 3 sistemas operativos, elige el tuyo:
https://dl.google.com/android/repository/tools_r25.2.5-windows.zip
https://dl.google.com/android/repository/tools_r25.2.5-macosx.zip
https://dl.google.com/android/repository/tools_r25.2.5-linux.zip
Después ejecuté el android, se me abrió el cmd y no se me cerró, pudiendose abrir así el SDK manager :), por mientras pondré que está solucionado, pero si tienen una solución sin descargarse una versión vieja no descarten ponerla aquí.

Actualización: No sé como ponerlo en solucionado, no encontré el prefijo xD, lo dejo sin nada.
« Última modificación: Enero 22, 2018, 05:00:35 pm por Baati »

Share via delicious Share via digg Share via facebook Share via furl Share via linkedin Share via myspace Share via reddit Share via stumble Share via technorati Share via twitter

xx
[ANDROID] - Clave Pública de la Licencia Para aplicación Android

Iniciado por Workod

3 Respuestas
1621 Vistas
Último mensaje Julio 23, 2014, 01:11:03 pm
por Workod
smiley
Aplicacion Killercreeper55 para ANDROID

Iniciado por JuanB_Uribe

4 Respuestas
1464 Vistas
Último mensaje Mayo 11, 2014, 06:19:27 pm
por sancanella
xx
Juego para Android: Moon's Meteors

Iniciado por Baati

0 Respuestas
18 Vistas
Último mensaje Febrero 16, 2018, 08:19:26 pm
por Baati
xx
Proyecto Launcher

Iniciado por LoliG4mer

2 Respuestas
723 Vistas
Último mensaje Junio 03, 2016, 07:50:29 pm
por LoliG4mer